MacでPythonがビルド出来ない

python install しようとした際にエラーが発生。

$ pyenv install 2.7.11
-> https://www.python.org/ftp/python/2.7.11/Python-2.7.11.tgz
Installing Python-2.7.11...
ERROR: The Python zlib extension was not compiled. Missing the zlib?
Please consult to the Wiki page to fix the problem.
https://github.com/yyuu/pyenv/wiki/Common-build-problems

BUILD FAILED (OS X 10.11.3 using python-build 20160130)

zlibが無いとのエラー....Mavericks以降で起きる事象だそうな。 最近Mavericks飛び越えてEl Capitanへ上げたのでそれで起こった。

zlibのインストール

XCodeツールをインストールすればOK。

$ xcode-select --install

Related Posts